You are using an unsupported browser. Please update your browser to the latest version on or before July 31, 2020.
close

Why am I getting an "unsupported browser" message in Canvas?

If you are receiving the following error message, it is because you are using a browser that is not officially supported by Canvas. If you are using Google Chrome Enterprise or Firefox ESR (which are often used in computer labs), then you will receive this error message if the browser is 2 versions or more behind the latest browser version.

Error message:

Your browser does not meet the minimum requirements for Canvas. Please visit the Canvas Community for a complete list of supported browsers.

Solution:

The solution to this problem is to switch to a different browser, or to update your browser. If you prefer to use Firefox, you can use the two most recent Firefox releases which are different versions from Firefox ESR. If you are in a computer lab and unable to download or install an Firefox updates, then we recommend using a different browser that is already installed on the computer. Please see our Technology Recommendations for FSU's Canvas for a list of browser recommendations.

  • 1327
  • 09-Jun-2020
  • 2551 Views